
 

บทที ่3 
ตัวอยางการใชงาน 

 
 
 
 
 
 
3.1 การวิเคราะหปญหาคานใน 2 มิติ 

ขั้นตอนเบื้องตนในการเริ่มใชงาน โปรแกรม STAAD/Pro ดูรายละเอียดไดจากเนือ้หาใน
บทที่ 1 และบทที่ 2 ตามที่ไดกลาวมาแลว สําหรับปญหาคานใน 2 มิติ ประเภทของ
โครงสรางที่เหมาะสมคือ PLANE ซ่ึงเหมาะสมกับปญหาทั่วไปในระนาบ ดังแสดงใน
ตัวอยางที่ 1 
 
ตัวอยางที่ 1 จงหาแรงปฏิกิริยาของคานตอเนื่องตอไปนี ้
 
 
 
 
 
 
วิธีทํา 
เนื่องจากปญหาขอนี้ตองการทราบเพียงคาปฏิกิริยา ไมไดสนใจคาการเสียรูปจึงไมกําหนด
คุณสมบัติหนาตัด และคุณสมบัติวัสดมุาให แตคาดังกลาวก็ยังจําเปนตองปอนใหแก
โปรแกรม โดยทําการสมมตขิึ้น ซ่ึงจะไมมผีลตอการคํานวณหาคาแรงปฏิกิริยาแตอยางใด 
 

2 m 1 m 3 m 

1000 kg 400 kg/m 
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ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 2 โปรแกรมจะเขาสูหนายอย Setup > Job โดยอัตโนมัต ิ ปอนขอมูลในกลอง
โตตอบ Job Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดง
กลองโตตอบ Snap Node/Beam พรอมดวยตาราง Nodes และ Beams ดังรายละเอียดใน
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หัวขอ 2.1 ผูใชอาจจะเลือกที่จะปอนคาพกิัดจุดตอแลวคอยสรางองคอาคารจากจุดตอ ใน
ตารางก็ได สวนตัวอยางนี้จะแสดงวิธีใชตวัเลือก Snap Node/Beam ดังภาพ  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เมื่อทําเสร็จแลวจะเหน็ไดวา ตาราง Nodes และ Beams มีขอมูลตัวเลขของจุดตอและคาน
ตามที่สราง ผูใชสามารถแกไขคาในตาราง ซ่ึงจะสงผลใหแบบจําลองในเมนวินโดว
เปลี่ยนแปลงไปดวย  
 
ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร สําหรับโจทยปญหานี ้ จะเลือกหนาตัดจากตารางเหล็กมาตรฐาน เพื่อ
ความรวดเร็ว ตามเหตุผลที่ไดกลาวมาแลว  

1

2

4

5 6 7

เลือกระนาบที่ตองการทํางาน 
(โดยทั่วไปจะคุนเคยกับ x-y สําหรับปญหา 2 มิติ) 

เลือกการแสดงผลดานหนา (Front View) 

กําหนดขนาดของกริด ซึ่งปญหาขอนี้ ระยะที่
เหมาะสมคือ 1 m 

3คลิกเลือก (ใหยุบลง) เพื่อสราง
แบบจําลองจากเมนวินโดว 

คลิกเลือกจุดที่ตองการตามลําดับ เมื่อใชวิธี Snap 
Node/Beam เพียงเลือกจุดที่ใกลเคียงโปรแกรมจะ
เลือกสรางจุดตอที่จุดตัดของเสนกริดโดยอัตโนมัติ 

แสดงระนาบที่กําลังแสดงผลอยู (x-y) 



 
บทที่ 3 ตัวอยางการใชงาน 

 

64

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

1 

2 3 

4

5

6 

7 

หมายเลขจุดตอ 

หมายเลของคอาคาร หมายเลขอางอิงคุณสมบัติ 

เลือกตารางเหล็กมาตรฐาน ตารางเหล็กมาตรฐานอเมริกัน 

เลือกมาตรฐาน 

กําหนดคุณสมบัติใหแก
โครงสรางทั้งหมดในมุมมอง 
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ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 3 แบบ คือ แบบยึดแนน (Fixed) แบบหมุนได (Pinned) และเลื่อนได (Roller) โดย
สรางรูปแบบจุดรองรับทั้ง 3 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจดุตอที่
ตองการทีละจดุตามลําดับ ดวย Node Cursor  
 
 

- ตัวเลือก Assign ในกลองโตตอบ American Steel Table จะใชไดก็ตอเมื่อผูใชได
เลือกองคอาคารในเมนวินโดวกอนทีจ่ะเขาสูขั้นตอนการเลือกหนาตัด 

- ตัวเลือก Assign To Selected Beam ในกลองโตตอบ Properties จะใชไดก็ตอเมื่อ
ผูใชเลือกองคอาคารในเมนวินโดวกอน ดวยไอคอน Beam Cursor  หรือ 
Geometry Cursor   ในทูลบาร 

- ตัวเลือก Use Cursor to Assign ใชงานคลิกที่ปุม Assign (ซ่ึงจะยุบคางไว) แลว
ใชเมาสคลิกที่องคอาคารที่ตองการ เมื่อเสร็จแลวคลิกที่ปุม Assign อีกครั้งเพื่อ
หยุดการทํางาน 

- ถาผูใชตองการใหแสดงหมายเลขจุดตอ หรือ หมายเลของคอาคาร ทําไดโดยใช
คําสั่ง View > Structure Diagrams > Labels หรือไอคอน Symbols and Labels 

 ในทูลบาร แลวเลือก Node Numbers และ Beam Numbers (ใหแสดง
เครื่องหมายถกู) หรืออาจจะเลือกการแสดงผลคําอธิบายอื่นๆ ไดตามตองการ
ดวยวิธีการเดียวกัน 

 

 

TIPS 
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2 

4

1

3

5

7 

6 

Fixed 
Pinned 
Roller 

8 

11

14

9 12 15 

10, 13, 16  

TIPS จุดรองรับแบบ Roller สรางไดโดยใชตัวเลือก Fixed But ซึ่งกรณีนี้การบังคับ (Restraint) มีเฉพาะ
ทิศทางโกลบอล Y จึงคลิกรีลีสแรงทั้งหมดยกเวน FY ดังภาพ (หมายความวาเลื่อนที่หรือหมุนได 
ยกเวนทิศทาง Y) 

ดูภาคผนวก ค. 

CAUTION!! 
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ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงประกอบดวยน้ําหนักกระทําเปนจุด (Concentrated 
Force) และน้ําหนักแผกระจายคงที่ (Uniform Force) โดยคลิกที่ Member… 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
-  

1
2 

3

4 5

6 
7

9

10 

8 

สําหรับน้ําหนกัแผกระจายคงที่ ถาใหคา d1 และ d2 เทากับ 0 จะหมายถึงน้ําหนกัแผ
กระจายเต็มความยาวคาน 

TIPS 
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ทําการ Assign น้ําหนกัใหแกคานแตละตัวดวยคําสั่ง Assign To Selected Beams ดวย
วิธีการดังที่คลายคลึงกับขั้นตอนที่ 3 แตเลือกที่คานดวย Beam Cursor   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
 หรืออาจจะกําหนดจากเพจคอนโทรล ตามที่ไดกลาวไวแลวในบทที ่ 2 โดยที่
ขั้นตอนนี้จะขาดไปไมได เพราะจะไมสามารถเขาสูโหมดการแสดงผลการวิเคราะหได 

 

- การกําหนดใหแสดงคาน้ําหนักดวย ทําไดโดยคําสั่ง View > Structure 
Diagrams > Labels หรือไอคอน Symbols and Labels  ในทูลบาร แลวเลือก 
Load Value (ใหแสดงเครื่องหมายถูก)  

- หนวยที่แสดง จะแสดงเปน kN แมวาจะปอนคาเปน kg (แตจะไมมีผลตอการ
คํานวณ)ดไูดจาก View > Options > Force Units ซ่ึงใชกําหนดหนวยในการ
แสดงผลมีตัวเลือกแยกออกเปนสองกลุมหลักคือ kN และ lb เทานั้น   

NOTES 
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ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
 
 
 
 
 
 
 
 
 
 
ผูใชสามารถเลือกดูคาการแสดงผลไดตามตองการ แตสําหรับปญหานีท้ี่เราสนใจคือคาแรง
ปฏิกิริยาซึ่งดูไดจากหนายอย Node > Reactions และการเสียรูปจากหนายอย Node > 
Displacement หรือจากไอคอน Deflections  ไดโดยตรง 
 
 
 
 

 

1 
2

3

Deflection 
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และจากหนายอย Beam > Forces จะสามารถคาของแรงในคานพรอมทั้งแผนภาพได หรือ
โดยใชไอคอนโดยตรง ไดแก Bending Z Moment    Shear Y Force  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Reactions 

Bending Moment Diagram 

Shear Force Diagram 

การปรับขนาดรูปภาพในการแสดงผล ใหขยายขึ้นหรือเล็กลงทําไดโดยใชคําสั่ง View 
> Structure Diagrams > Scales หรือจากไอคอน Scales  ถาตองการใหขยายขึ้นให
ปรับคาตัวเลขใหนอยลง และในทางกลับกนัถาตองการใหเล็กลง ก็ปรับคาตัวเลขให
เพิ่มขึ้น  

TIPS 
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สวนหนายอย Beam > Graphs จะเปนการแสดงผลทีละองคอาคาร ในรูปกราฟกพรอม
แสดงคาแรงตวัเลขดวย 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 9 การสรางรายงาน ทําไดโดยเขาสูหนาหลัก Reports จากเพจคอนโทรล หรือ
จากเมนูบาร Report Setup  เมื่อเลือกรายการที่ตองการแลวสามารถดูตัวอยางกอนพิมพ
ไดดวยไอคอน Print Preview   จะไดรายงานที่จัดพิมพสําเร็จดังแสดงในภาคผนวก ข. 
 

Bending Moment Diagram 

Shear Force Diagram 

Bending Moment Diagram 

Shear Force Diagram 
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3.2 การวิเคราะหปญหาโครงขอหมนุใน 2 มิติ 
สําหรับโครงขอหมุน ควรเลอืกประเภทการวิเคราะหเปน TRUSS ซ่ึงหมายถึงโครงสราง
รับแรงตามแนวแกนเทานัน้ ซ่ึงจะชวยลดความยุงยากในการคํานวณลงไดมาก 
 
ตัวอยางที่ 2 จงวิเคราะหโครงขอหมุนตอไปนี้ กําหนดให E = 2 x 108 kN/m2 และ A = 6 x 
10-4 m2 สําหรับทุกชิ้นสวน 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  

150 kN

120 kN 

6@0.5 = 3.0 m 

0.7 
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- ที่ตัวเลือก Structure Type ใหเลือก TRUSS  
- ที่ตัวเลือก Length Units ใหเลือก Meter 
- ที่ตัวเลือก Force Units ใหเลือก KiloNewton 
 
ขั้นตอนที่ 2 เมื่อโปรแกรมจะเขาสูหนายอย Setup > Job ปอนขอมูลในกลองโตตอบ Job 
Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดงกลองโตตอบ 
Snap Node/Beam ใหเลือกระนาบทํางานเปน X-Y พรอมทั้งตั้งระยะกริดใหมเพื่อให
สะดวกในการสรางแบบจําลอง ดังตัวอยาง 
 
 
 
 
 
 
 
 
 
 
 
 
คลิกที่ Snap Node/Beam จะชวยในการสรางแบบจําลอง ไดโดยคลิกทีจ่ดุตัดของเสนตาราง
ที่ไดตั้งคาไวแลว เมื่อคลิกทีจุ่ดตอ 1 และจุดตอ 2 ดวยเครื่องหมายกากบาท โปรแกรมจะ
สรางองคอาคารหมายเลข 1 ขึ้นมาโดยอัตโนมัติ และเมื่อคลิกที่จุดตอ 3 โปรแกรมก็จะสราง
องคอาคารหมายเลข 2 จากจดุตอ 2 ไปยังจดุตอ 3 โดยอัตโนมัติเชนกนั 
 
 
 
 

 
1 

2 

1

2

3 
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แตเนื่องจากเราตองการสรางองคอาคารหมายเลข 2 จากจุดตอ 1 ไปยงัจุดตอ 3 (ดโูจทย
ประกอบ) เราจึงตองยายจุดสีแดง (Hot Grips) ซ่ึงเปนจดุเริ่มตนขององคอาคารใหม จากจุด
ตอ 2 ไปยงัจดุตอ 1 ดวยการกด Ctrl คางไวแลวคลิกที่จุดตอ 1 จะเห็นไดวาจุดสแีดงจะ
ปรากฏที่จุดตอ 1 ปลอย Ctrl แลวคลิกทีจุ่ดตอ 3 โปรแกรมจะสรางองคอาคารหมายเลข 2 
ขึ้นดังภาพ  
 
 
 
 
 
 
ทําเชนเดยีวกนัเพื่อสรางแบบจําลองใหมหีมายเลขของจุดตอและองคอาคารเปนดังที่โจทย
กําหนด 
 
 
 
 

 
ซ่ึงโดยทั่วไปแลว เรามักจะกําหนดจุดตอหมายเลขที่มีคาต่ํากวาเปนจดุเริ่มตน ไปยงัจุดตอ
หมายเลขที่มีคามากกวา  
 
 
 
 
 
 
 
 
 
 

1+Ctrl 
2 

TIPS นอกจากวิธีขางตนแลว เราอาจจะสรางแบบจําลองโดย สรางเฉพาะจดุตออยางเดยีว
ตามลําดับที่ตองการ แลวคอยใชคําสั่ง Add Beam สรางองคอาคารระหวางจุดตอที่
ตองการ 

- กด Ctrl คางไวตลอดแลวคลิกที่ตําแหนงจุดตอที่ตองการตามลําดับ จนครบ 
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ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร สําหรับโจทยปญหานี ้โจทยกําหนดพืน้ที่หนาตดั (A) สวนคุณสมบัติวัสดุ 
โจทยกําหนดคาโมดูลัสยืดหยุน (E) มาให ซ่ึงพอเพียงสําหรับโครงสรางแบบ TRUSS  
คลิกที่ Define… เลือก General เพื่อสรางคุณสมบัติหนาตัด 
 
 
 
 
 
 
 
 
 
 
 
 

 

TIPS (ตอ)  
- คลิกที่ Snap Node/Beam เพื่อยกเลิกการใชงาน (ปุมนนูขึ้น) คลิกที่ทลูบาร Add 

Beams   หรือจากเมนูบาร Geometry > Add Beam เพื่อสรางองคอาคาร 
โดยคลิกที่จุดตอเร่ิมตนและจุดตอปลายทางตามลําดับ โปรแกรมจะสรางองค
อาคารขึ้นมาให สําหรับองคอาคารตอไปก็ตองคลิกจุดตอเร่ิมตนและจดุตอ
ปลายทาง 2 จดุเชนเดมิ 

 
 

1, 3 
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4
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4คลิกเครื่องหมาย√ ออก เพื่อจะกําหนด
คุณสมบัติวัสดุดวยตนเองภายหลัง 
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จะได 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 2 แบบ คือ แบบหมุนได (Pinned) และเลื่อนได (Roller) โดยสรางรูปแบบจุด
รองรับทั้ง 2 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจุดตอที่ตองการทีละจุด
ตามลําดับ ดวย Node Cursor  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

หมายถึง Ref 1 ในตารางคุณสมบัติ 
Properties > Section 

จุดรองรับแบบ Roller 

Assign Support 2 (Pinned) Assign Support 3 (Roller) 
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จะได 
 
 
 

 
 

 
 
 
 
 
 
ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงประกอบดวยน้ําหนักกระทําเปนจุด (Concentrated 
Force) กระทําที่จุดตอ คลิกเลือก Nodal… เพื่อสรางน้ําหนักบรรทุก 2 รายการ แลว Assign 
ใหแกแตละจุด โดยใช  Node Cursor เลือกจุดตอที่น้ําหนกักระทําแลวใชตัวเลือก Assign 
To Selected Node เพื่อกําหนดจุดตอทีก่ระทํา 
 
 
 
 
 
 
 
 
 
 
 
 
 

TIPS ในกรณีที่ตองการลบจุดรองรับออกจากโครงสรางทําไดโดย Assign S1 (No Support) 
ใหแกจุดตอทีม่ีจุดรองรับเดมิอยู  
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ทําการบันทึกภาพ ไวเพื่อใชประกอบรายงานดวยไอคอน Take Picture     
 
 
 
 
 
 
 
 
 
 
 
 
จะเห็นไดวา เรายังไมไดกําหนดคณุสมบัติวัสดุใหแกโครงสราง ทําใหยังไมสามารถทําการ
วิเคราะหได  
ทําการกําหนดโมดูลัสยืดหยุนใหแกองคอาคารในโครงสรางไดโดย ใชคําสั่ง Commands > 
Material Constants > Elasticity … แลวกาํหนดคาใหแกทั้งโครงสรางโดยเลือกตวัเลือก To 
View  
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
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79

 
ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 
ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
เลือกดูการแสดงผลแรงปฏิกิริยา (Reactions) และการเสียรูป (Displacements) แลว
บันทึกภาพดวยคําสั่ง Take Picture เพื่อใชประกอบในรายงาน 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

TIPS - ถาตองการใหภาพกราฟกแสดงหมายเลขจุดตอ, หมายเลของคอาคาร หรือ
ขนาดของแรงใหกําหนดดวยไอคอน Symbols and Labels   

- ถาตองการใหแสดงรูปน้ําหนักบรรทุกใหคลิกที่ไอคอน Loads  
- ถาตองการเปลี่ยนหนวยของแรง เชน kN ในการแสดงใหใชคําสั่ง Tool > Set 

Current Unit…  จากเมนูบาร แลวเลือกหนวยใหมตามตองการ 
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ขั้นตอนที่ 9 การสรางรายงาน โดยเขาสูหนาหลัก Reports จากเพจคอนโทรล หรือจากเมนู
บาร Report Setup  เมื่อเลือกรายการที่ตองการแลวสามารถดูตัวอยางกอนพิมพไดดวย
ไอคอน Print Preview   จะไดรายงานที่จดัพิมพสําเร็จดังแสดงในภาคผนวก ข. 
 
 
 
 
 
 
 
 
 
 
 
 

นอกจาก Reports แลว STAAD ยังมีการรายงานผลในรูปแบบแฟมขอมูลเอกสาร 
(นามสกุล .ANL) ซ่ึงเปนผลจากการเลือกในขั้นตอนหนาหลัก Analysis/Print สามารถ
เรียกดไูดโดยคลิกไอคอน STAAD Output หรือคําสั่งจากเมนูบาร File > View > Output 
File > STAAD Output ก็ได ตัวอยางของรายงานแบบนี้แสดงใน ภาคผนวก ข.  

 
3.3 การวิเคราะหปญหาโครงขอแข็งใน 2 มิติ 

สําหรับปญหาโครงขอแข็ง (Frame Structures) ใน 2 มิต ิประเภทการวเิคราะหที่เหมาะสม
ควรจะใชตัวเลือก PLANE ซ่ึงหมายถึงปญหาในระนาบ  
 
ตัวอยางที่ 3 จงวิเคราะหโครงขอแข็งตอไปนี้ กําหนดให E = 3 x 104 kip/in2 และ มีขนาด
หนาตัด A = 2 in2 และโมเมนตความเฉื่อย I = 100 in4 สําหรับทุกหนาตดั  
เนื่องจากโครงสรางมีหนวยเปน ft (Foot) และแรงในโครงสรางเปน kip (KiloPound) จึงทํา
การเลือกหนวยดังกลาวในขัน้ตอนที่ 1 แตพบวา  
 

 

ใชเลื่อนเพื่อสลับลําดับ
การแสดงผลได 
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1 

10 kip 
100 kip-in 

แมจะเลือกหนวยเปน Foot และ KiloPound 
แลวแตการแสดงผลหนาจอของโปรแกรมยังคง
เปน m (Meter) อยู ซึ่งไมสามารถแกไขไดดวย
คําสั่ง Tools > Set Current Unit… (ใชกําหนดคา
การแสดงผลในรายงาน)  
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วิธีแกไขทําไดโดยกําหนดคาหนวยพืน้ฐาน (Base Unit) ใหม จากเมนูบาร File > 
Configure… เลือกแท็บ Base Unit แลวเลือกเปลี่ยนจาก Metric เปน English  
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  
- ที่ตัวเลือก Structure Type ใหเลือก PLANE  
- ที่ตัวเลือก Length Units ใหเลือก Foot 
- ที่ตัวเลือก Force Units ใหเลือก KiloPound 
 
ขั้นตอนที่ 2 เมื่อโปรแกรมจะเขาสูหนายอย Setup > Job ปอนขอมูลในกลองโตตอบ Job 
Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดงกลองโตตอบ 
Snap Node/Beam ใหเลือกระนาบทํางานเปน X-Y พรอมทั้งตั้งระยะกริดใหมเพื่อให
สะดวกในการสรางแบบจําลอง ดังตัวอยาง แลวสรางแบบจําลองตามขอมูลจากโจทย 
 
 
 
 
 

เมื่อเปลี่ยนหนวยที่พืน้ฐานแลว คลิก Accept โปรแกรมจะทําการปดตวัเองโดยอัตโนมัต ิ
เพื่อปรับปรุงคาในตวัโปรแกรมใหม 

NOTES 
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ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร สําหรับโจทยปญหานี ้โจทยกําหนดพืน้ที่หนาตดั (A) และ โมเมนตความ
เฉื่อยของหนาตัด (I) สวนคุณสมบัติวัสด ุ โจทยกําหนดคาโมดูลัสยืดหยุน (E) มาให ซ่ึง
พอเพียงสําหรับโครงสรางแบบโครงขอแข็ง  
 เนื่องจากหนวยของคุณสมบตัิที่กําหนดใหเปน in (inch) เพื่อความสะดวกจึง
กําหนดหนวยใชงานใหม ดวยคําสั่ง Tools > Set Current Unit… แลวเปลี่ยน Length Units 
ใหเปน Inch 
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คลิกที่ Define… เลือก General เพื่อสรางคุณสมบัติหนาตัด แลวกําหนดคุณสมบัติ

หนาตัดดังกลาวใหแกโครงสรางดวยตวัเลือก Assign to View 
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ทําการกําหนดโมดูลัสยืดหยุนใหแกองคอาคารในโครงสรางไดโดย ใชคําสั่ง Commands > 
Material Constants > Elasticity … แลวกาํหนดคาใหแกทั้งโครงสรางโดยเลือกตวัเลือก To 
View  
 
 
 
 
 
 

 
 
ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 2 แบบ คือ แบบหมุนได (Pinned) และแบบยดึแนน (Fixed) โดยสรางรูปแบบจุด
รองรับทั้ง 2 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจุดตอที่ตองการทีละจุด
ตามลําดับ ดวย Node Cursor  
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ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงประกอบดวยน้ําหนักกระทําเปนจุด (Concentrated 
Force) และโมเมนต (Moment) กระทําที่จุดตอ คลิกเลือก Nodal… เพื่อสรางน้ําหนกั
บรรทุก 2 รายการ แลว Assign ใหแกแตละจุด โดยใช  Node Cursor เลือกจุดตอที่
น้ําหนกักระทาํแลวใชตวัเลือก Assign To Selected Node เพื่อกําหนดจุดตอที่กระทํา 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
 
ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 
ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
เลือกดูการแสดงผลแรงปฏิกิริยา (Reactions) และการเสียรูป (Displacements) แลว
บันทึกภาพดวยคําสั่ง Take Picture เพื่อใชประกอบในรายงาน 
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ขั้นตอนที่ 9 การสรางรายงาน โดยเขาสูหนาหลัก Reports จากเพจคอนโทรล หรือจากเมนู
บาร Report Setup  เมื่อเลือกรายการที่ตองการแลวสามารถดูตัวอยางกอนพิมพไดดวย
ไอคอน Print Preview   จะไดรายงานที่จดัพิมพสําเร็จดังแสดงในภาคผนวก ข. 
 
 

 
 

Reactions 
Deflected Shape Diagram 

Shear Force Diagram Bending Moment Diagram 
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3.4 การวิเคราะหปญหาพิเศษ 
เนื้อหาในสวนนี้จะเนนหนักไปที่การสรางแบบจําลอง เพื่อการวิเคราะหโครงสรางที่มี
รูปแบบพิเศษ เชน จุดรองรับแบบเอียง (Inclined Support) จุดหมนุภายใน (Internal Hinge) 
เปนตน โดยการอธิบายจะบรรยายเฉพาะทีจ่ําเปน ขั้นตอนการทํางานพืน้ฐานที่เปนขั้นตอน
ตามปกติ กใ็หปฏิบัติเชนเดียวกับหวัขอ 3.1 ถึงหัวขอ 3.3  
 
ตัวอยางที่ 4 จากโครงขอแข็งในตวัอยางที่ 3 ที่จุดตอหมายเลข 3 เปลี่ยนจากจุดยึดแนน เปน
แบบหมุนได (hinge) สวนตวัแปรอื่นยังคงเดิม 
  
 
 
 
 
 
 
 
 
 1 

10  kip 
100 kip-in 
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การปฏิบัติในขั้นตอนที่ 1 ถึง ขั้นตอนที ่ 5 ก็ทําเชนเดียวกับตวัอยางที่ 3 โดยมีขัน้ตอน
เพิ่มเติมคือการปรับแตงคุณสมบัติขององคอาคาร ใหสามารถหมุนไดที่จุดตอหมายเลข 2 
(ไมสามารถรับโมเมนตได) ซ่ึงผูใชสามารถที่จะเปดแฟมขอมูลเดิมในตัวอยางที่ 3 มาแกไข
โดยไมตองสรางแฟมขอมูลใหมก็ได โดยใชคําสั่ง File > Save As… แลวบันทกึเปนแฟม
งานใหม 
 
 
 
 
 
 
 
 
 
เขาสูหนายอย General > Spec เพื่อทําการรีลีสองคอาคาร โดยคลิกที่ Beam… ในกลอง
โตตอบ Specifications   
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 
2

3

4 

5

ทําการรีลีสโมเมนตรอบแกน Z (ใหหมุนได) ที่
จุดเริ่มตนขององคอาคาร (Start) 
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ทําการ Assign คุณสมบัติการรีลีสโมเมนตที่เลือกไวใหแกองคอาคารที่ตองการ ดวย
ตัวเลือก Assign To Selected Beams โดยกาํหนด START MZ ใหแกคานหมายเลข 2 และ
กําหนด END MZ ใหแกคานหมายเลข 1  
 

ทําการรีลีสโมเมนตรอบแกน Z (ใหหมุนได) ที่จุด
ปลายขององคอาคาร (End) 

6 
7 

8 

9 

10, 13 

11

14 

12, 15
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ใน ขั้นตอนที ่  6 ถึง ขั้นตอนที่ 8 ก็เปนเชนเดยีวกับตัวอยางที่ 3 จะไดผลการวิเคราะห
ดังตอไปนี้  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ตัวอยางที่ 5 ปญหาที่รองรับเอียง (Inclined Support) สําหรับปญหาโครงขอหมุนรูป
สามเหลี่ยมดานเทาความยาวเทากับ 3 m มีคาโมดูลัสยืดหยุน E = 210 kN/mm2 
พื้นที่หนาตัด A = 4 x 103 mm2 สําหรับทุกชิ้นสวน 
  
 

Reactions 
Deflected Shape Diagram 

Shear Force Diagram Bending Moment Diagram 
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เนื่องจากปญหานี้ใชหนวยเมตริก จึงตองตัง้คาการแสดงผลของโปรแกรม โดยกําหนดคา
หนวยพืน้ฐาน (Base Unit) ใหม จากเมนบูาร File > Configure… เลือกแท็บ Base Unit 
แลวเลือกเปลี่ยนจาก English เปน Metric 
 
ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  
- ที่ตัวเลือก Structure Type ใหเลือก TRUSS  
- ที่ตัวเลือก Length Units ใหเลือก Meter 
- ที่ตัวเลือก Force Units ใหเลือก KiloNewton 
 
ขั้นตอนที่ 2 เมื่อโปรแกรมจะเขาสูหนายอย Setup > Job ปอนขอมูลในกลองโตตอบ Job 
Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดงกลองโตตอบ 
Snap Node/Beam ใหเลือกระนาบทํางานเปน X-Y พรอมทั้งตั้งระยะกริดใหมเพื่อให
สะดวกในการสรางแบบจําลอง ดังตัวอยาง แลวสรางแบบจําลองตามขอมูลจากโจทย 

เนื่องจากความยาวคาน 3 m เปนความยาวตามแนวเอียง จึงตองแปลงพกิัดของจุด
ตอใหเปนพิกดั X-Y ซ่ึงติดอยูในรูปคา Sin และ Cos ซ่ึงไมสามารถปอนใหโปรแกรมได
โดยตรง ตองคํานวณเปนตวัเลขซึ่งไมลงตัว แลวปอนคาที่คํานวณไดดังกลาวลงในตาราง
พิกัด Nodes แตผูใชสามารถใชเทคนิคเพื่อใหไดคาพิกัดที่ถูกตองมากที่สุด โดยใชการหมุน
ระนาบ (Angle of  Plane) ดังแสดงตอไปนี้ 

50 kN 

50 kN 

45° 30° 

60° 60° 

60° 
50 kN 

50 kN 

1 

2 

3 

1 

2 

3 

30° 
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1

2

3

4 

5 

6 

หมุนระนาบ Z – Z ไป 30 องศา เพื่อ
สรางองคอาคารหมายเลข 1 จากจุดตอ
หมายเลข 1 ไปยังจุดตอหมายเลข 2 
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ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร โดยกําหนดหนวยดวยคําสั่ง Tools > Set Current Unit ใหเปน Millimeter 
คลิกที่ Define… เลือก General เพื่อสรางคุณสมบัติหนาตัด  
 
 
 
 
 
 
 
 
 
 

1 

2+Ctrl 

3, 7

4

5 
6 

หมุนระนาบ Z – Z กลับไปยังตําแหนงเดิม 

สรางองคอาคารจากจุดตอ 1 ไปจุดตอ 3 แตเมื่อจะสรางจากจุดตอ 2 ไป
ยังจุดตอ 3 จะเห็นวาไมสามารถเลือกจุดตอ 2 ไดเพราะไมใชตําแหนง
เสนกริด ตองใชวิธี Add Beam โดยยกเลิก Snap Node/Beam 

สรางองคอาคารจากจุดตอ 1 ไปจุดตอ 3 

1

2 

3
4 

5 
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ทําการกําหนดโมดูลัสยืดหยุนใหแกองคอาคารในโครงสรางไดโดย ใชคําสั่ง Commands > 
Material Constants > Elasticity … แลวกาํหนดคาใหแกทั้งโครงสรางโดยเลือกตวัเลือก To 
View  
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 2 แบบ คือ แบบหมุนได (Pinned) และแบบเลือ่น (Roller) ซ่ึงเปนแบบเอยีง โดย
สรางรูปแบบจุดรองรับทั้ง 2 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจดุตอที่
ตองการทีละจดุตามลําดับ ดวย Node Cursor  
 
 
 
 
 
 
 
 
 
 
 
 
 

1 

2

ดูภาคผนวก ค. 

CAUTION!! 
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ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงประกอบดวยน้ําหนักกระทําเปนจุด (Concentrated 
Force) 2 ทิศทาง กระทําทีจุ่ดตอจุดเดยีว ซ่ึงสามารถรวมเปนรายการเดียวกันได คลิกเลือก 
Nodal… เพื่อสรางน้ําหนักบรรทุก แลว Assign ใหแกแตละจดุ โดยใช  Node Cursor 
เลือกจุดตอที่น้าํหนักกระทําแลวใชตัวเลือก Assign To Selected Node เพื่อกําหนดจดุตอที่
กระทํา 
 
 
 
 
 
 
 
 
 
 

จุดอางอิง (Inclined Reference Point) ของที่รองรับแบบเอียงคือ จุดสมมติที่เทียบกับจดุ
รองรับ โดยวดัในแกนพิกัดโกลบอล ซ่ึงจะสรางแกนพิกดัโลคอลในทิศทางดังตัวอยาง 
ซ่ึงจะใชอางองิในการรีลีสแรงในทิศทางทีต่องการตอไป 
 

NOTES 

X 

Y 

x 
y 

Global 

Local 

30° 

30° 3  

1 
2 
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ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
 
ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 
ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
เลือกดูการแสดงผลแรงปฏิกิริยา (Reactions) และการเสียรูป (Displacements) แลว
บันทึกภาพดวยคําสั่ง Take Picture เพื่อใชประกอบในรายงานตอไป ซ่ึงจะไมขอกลาวใน
รายละเอียด  
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คาแรงปฏิกิริยาที่แสดง จะอยูในพิกัดโกลบอล ซ่ึงคาที่แสดงในตารางจะมีความถูกตอง
มากกวา ตองรวมแรงทั้งสองใหอยูในพกิัดโลคอล จึงจะไดแรงปฏิกิริยาที่แทจริง 
สวนที่แสดงในภาพกราฟก คาแรงปฏิกิริยาในทิศทาง X ยังไมเปนคาจริง เปนเพียงการดึง
คาที่คํานวณจากตารางมาแสดงผล และทิศทางที่ถูกรีลีส เชน Y ก็จะไมแสดงผล 

Reactions Deflected Shape Diagram 

CAUTION!! 

- เมื่อทดลองกําหนดคาจดุอางอิง (Inclined Reference Point) ให X = 1.0 Y=1.732 
Z=0 (ซ่ึงเปนจดุตรงกันขามกบัจุดเดิม) พบวาแรงปฏิกิริยาที่คํานวณไดมีคา
เชนเดิม 

- ถากําหนดจุดอางอิง ให X=-1.732 Y=1.0 Z=0 แลวรีลีส FX FZ MX MY MZ โดย
ใหแรงปฏิกิริยาอยูในทิศทางโลคอล Y แทน ก็จะไดผลลัพธเชนเดยีวกนั (ซ่ึง
ตําแหนงดังกลาวคือจุดยอดมมุของฐานรองรับนั่นเอง) 

 

NOTES 

30° 
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ตัวอยางที่ 6 ปญหาที่รองรับเกิดการทรุดตัว (Settlement) พิจารณาโครงขอหมุน ซ่ึงมีคา
โมดูลัสยืดหยุน E = 210 kN/mm2 และเกดิการทรุดตัว 20 mm ที่จุดตอหมายเลข 2 ดังภาพ 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  
- ที่ตัวเลือก Structure Type ใหเลือก TRUSS  
- ที่ตัวเลือก Length Units ใหเลือก Meter 
- ที่ตัวเลือก Force Units ใหเลือก KiloNewton 
 
ขั้นตอนที่ 2 เมื่อโปรแกรมจะเขาสูหนายอย Setup > Job ปอนขอมูลในกลองโตตอบ Job 
Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดงกลองโตตอบ 
Snap Node/Beam ใหเลือกระนาบทํางานเปน X-Y พรอมทั้งตั้งระยะกริดใหมเพื่อให
สะดวกในการสรางแบบจําลอง ดังตัวอยาง แลวสรางแบบจําลองตามขอมูลจากโจทย 
 
 
 
 
 

1 4 2 

2000 kN 

A = 60 cm2 A = 40 cm2 

A = 40 cm2 A = 40 cm2 

A = 20 cm2 

6.0 m 4.5 m 

4.5 m 
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ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร โดยกําหนดหนวยดวยคําสั่ง Tools > Set Current Unit ใหเปน Millimeter 
คลิกที่ Define… เลือก General เพื่อสรางคุณสมบัติหนาตัด ซ่ึงโจทยขอนี้มีคุณสมบัติหนา
ตัดที่แตกตางกนั 3 รูปแบบ ทําไดโดย Assign คุณสมบัตทิี่เหมาะสมใหแกองคอาคารทีละ
ช้ินดวยตวัเลือก Assign To Selected Beam…  

 

7 

8, 10 

1 

2

3+Ctrl 4+Ctrl 6+Ctrl

5+Ctrl

9, 13, 14

11, 12, 16 15, 17 
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ทําการกําหนดโมดูลัสยืดหยุนใหแกองคอาคารในโครงสรางไดโดย ใชคําสั่ง Commands > 
Material Constants > Elasticity … แลวกาํหนดคาใหแกทั้งโครงสรางโดยเลือกตวัเลือก To 
View  
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 2 แบบ คือ แบบหมนุได (Pinned) และแบบเลื่อนได (Roller) โดยสรางรูปแบบจุด
รองรับทั้ง 2 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจุดตอที่ตองการทีละจุด
ตามลําดับ ดวย Node Cursor  
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ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงประกอบดวยน้ําหนักกระทําเปนจุด (Concentrated 
Force) และแรงเนื่องจากการทรุดตัวของจดุรองรับ (Support Displacement) คลิกเลือก 
Nodal… เพื่อสรางน้ําหนักบรรทุก แลว Assign ใหแกแตละจดุ โดยใช  Node Cursor 
เลือกจุดตอที่น้าํหนักกระทําแลวใชตัวเลือก Assign To Selected Node เพื่อกําหนดจดุตอที่
กระทํา 
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ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
 
ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 
ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
เลือกดูการแสดงผลแรงปฏิกิริยา (Reactions) และการเสียรูป (Displacements) แลว
บันทึกภาพดวยคําสั่ง Take Picture เพื่อใชประกอบในรายงานตอไป ซ่ึงจะไมขอกลาวใน
รายละเอียด  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Reactions 

Deflected Shape Diagram 
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ตัวอยางที่ 7 ปญหาการเสียรูปเนื่องจากอณุหภูมิ (Temperature Load)  
พิจารณาทอทรงสี่เหล่ียมซึ่งมี คาสัมประสิทธการยืดหดตัวเนื่องจากอุณหภูมิ α = 

6 x 10-6 /°F และโมดูลัสยดืหยุน E = 5 x 103 k/in2 และมีขนาดดังภาพ อุณหภูมภิายใน
เทากับ 70° F สวนอุณหภูมภิายนอกเทากบั 110° F จงหาการเสียรูปเนื่องจากอณุหภูม ิ

ในการวิเคราะหจําเปนตองกาํหนดสภาวะขอบเขต (Boundary Condition) ใหแก
โครงสราง มิเชนนั้นโปรแกรมจะไมสามารถทําการวิเคราะหได โดยจุดรองรับที่กาํหนด
ใหแกโครงสรางคือ Hinge และ Roller ดังภาพ ซ่ึงจะยอมใหโครงสรางเสียรูปจากการหมุน
ไดและสามารถขยายตัวหรือหดตวัได 

 
 
 
 
 
 
 
 
เนื่องจากปญหานี้ใชหนวยอังกฤษ จึงตองตัง้คาการแสดงผลของโปรแกรม โดยกําหนดคา
หนวยพืน้ฐาน (Base Unit) ใหม จากเมนบูาร File > Configure… เลือกแท็บ Base Unit 
แลวเลือกเปลี่ยนจาก Metric เปน English 
 
ขั้นตอนที่ 1 เขาสูโปรแกรมเรียกคําสั่ง File > New จากเมนูบาร หรือจากไอคอน New 
Structure  บนทูลบาร เพื่อสรางแฟมงานใหม แลวปอนขอมูลที่จําเปนใหแกโปรแกรม
ตามลําดับ  
- ที่ตัวเลือก Structure Type ใหเลือก PLANE 
- ที่ตัวเลือก Length Units ใหเลือก Inch 
- ที่ตัวเลือก Force Units ใหเลือก KiloPound 
 
ขั้นตอนที่ 2 เมื่อโปรแกรมจะเขาสูหนายอย Setup > Job ปอนขอมูลในกลองโตตอบ Job 
Info ตามตองการ แลวเลือกหนายอย Geometry > Beam โปรแกรมจะแสดงกลองโตตอบ 
Snap Node/Beam ใหเลือกระนาบทํางานเปน X-Y คลิก Close เพื่อปดกลองโตตอบ แลว

T1 = 70° F 

T2 = 110° F 
1 4 

3 2 

1 
2 

3 

4 

2 “ 

6 “ 

44 “ 

16 “ 

T∆  = 40° F 
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ใชวิธีปอนคาพิกัดของจดุตอในตาราง Nodes แลวใชไอคอน Add Beams  สรางองค
อาคารที่ตองการตามลําดับจากจุดตอที่สรางขึ้น  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

ขั้นตอนที่ 3 ใชเพจคอนโทรล เขาสูหนายอย General > Property เพื่อกําหนดคุณสมบัติ
ใหแกองคอาคาร โดยกําหนดหนวยดวยคําสั่ง Tools > Set Current Unit ใหเปน Millimeter 

4, 7 2, 3 

1, 5 6, 8 
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คลิกที่ Define… เลือก Rectangle เพื่อสรางคุณสมบัติหนาตัด ซ่ึงโจทยขอนี้มีคุณสมบัติ
หนาตัดทีแ่ตกตางกัน 2 รูปแบบ แลว Assign คุณสมบัติที่เหมาะสมใหแกองคอาคารทีละ
ช้ินดวยตวัเลือก Assign To Selected Beam…  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

เราคิดเสมือนวาความหนาของกลองเปน
ความลึก (YD) ของคานสมมติ และคิดตอ
หนึ่งหนวยความยาว จึงกําหนดความกวาง 
(ZD) เทากับ 1  

โปรแกรมจะทําการคํานวณคุณสมบัติ
หนาตัดใหโดยอัตโนมัติ  
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ทําการกําหนดโมดูลัสยืดหยุนใหแกองคอาคารในโครงสรางไดโดย ใชคําสั่ง 
Commands > Material Constants > Elasticity … แลวกําหนดคาใหแกทั้งโครงสรางโดย
เลือกตัวเลือก To View  

 
 
 
 
 
 

 
 
ในทํานองเดียวกัน ทําการกําหนดคาสัมาประสิทธิ์การยดืหดตวัเนื่องจากอุณหภูมิ 

ใหแกองคอาคารในโครงสรางไดโดย ใชคาํสั่ง Commands > Material Constants > Alpha 
… แลวกําหนดคาใหแกทั้งโครงสรางโดยเลือกตัวเลือก To View  
 
 
 
 
 
 
 
 
ขั้นตอนที่ 4 เลือกหนายอย General > Support เพื่อที่จะใสจุดรองรับใหแกโครงสราง ซ่ึงมี
ทั้งหมด 2 แบบ คือ แบบหมนุได (Pinned) และแบบเลื่อนได (Roller) โดยสรางรูปแบบจุด
รองรับทั้ง 2 ขึ้นมากอนดวยคําสั่ง Add แลวจึง Assign ใหแกจุดตอที่ตองการทีละจุด
ตามลําดับ ดวย Node Cursor  
 
ขั้นตอนที่ 5 ทําการกําหนดน้าํหนักบรรทุกใหแกโครงสราง โดยเลือกทีห่นายอย General > 
Load สรางชุดน้ําหนกับรรทุกขึ้นมา ซ่ึงเปนน้ําหนักเนื่องจากอุณหภูม ิ (Temperature Load) 
คลิกเลือก Temp… เพื่อสรางน้ําหนกับรรทุก แลว Assign ใหแกแตละจุด โดยใช  Node 
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Cursor เลือกจุดตอที่น้ําหนกักระทําแลวใชตัวเลือก Assign To Selected Beams & Plates 
เพื่อกําหนดจดุตอที่กระทํา 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นตอนที่ 6 ทําการกําหนดคาการแสดงผล ในแฟมขอมูลผลลัพธ (.ANL) ไดโดยใชคําสั่ง
จากเมนูบาร Commands > Pre Analysis Print > Print All… และ Command > Analysis > 
Perform Analysis เลือก All   
 
ขั้นตอนที่ 7 ส่ังใหโปรแกรมทําการวิเคราะหดวยคําสัง่จากเมนูบาร Analyze > Run 
Analysis… เลือกทําการวิเคราะหดวย STAAD 
 

อุณหภูมิที่แตกตางของคาน มีคาเทากับ
อุณหภูมิที่ผิวบน – อุณหภูมิที่ผิวลาง ซึ่ง
จะทําใหคานเกิดการดัด (Bending)  

ตองสรางน้ําหนักบรรทุก 2 แบบ คืออุณหภูมิที่
ผิวบนสูงกวา (40) ไดแกองคอาคารหมายเลข 1, 
2, 4 และอุณหภูมิที่ผิวลางสูงกวา (-40) ไดแก
องคอาคารหมายเลข 3 ซึ่งพิจารณาไดจาก
จุดเริ่มตนและจุดปลายของคาน  

อุณหภูมิที่ทําใหเกิดการยืดหดตาม
แนวแกน (Elongation/Shrinkage)  
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ขั้นตอนที่ 8 เขาสูโหมดแสดงผลการวเิคราะหดวยคําสั่งจากเมนูบาร Mode > Post 
Processing หรือจากไอคอนบนทูลบาร  เลือกชุดน้ําหนักบรรทุกที่จะใชทําการแสดงผล 
เลือกดูการแสดงผลแรงปฏิกิริยา (Reactions) และการเสียรูป (Displacements) แลว
บันทึกภาพดวยคําสั่ง Take Picture เพื่อใชประกอบในรายงานตอไป ซ่ึงจะไมขอกลาวใน
รายละเอียด  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Reactions 

Deflected Shape Diagram 

Bending Moment Diagram 

Shear Force Diagram 
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